View Full Forums : Dell Says WoW NOT Compatible w/Vista

04-19-2007, 09:57 PM
I just got my Dell laptop XPS. I found my disks and loaded up WoW off a wireless router connection. But when it was running the patch it stopped at 21% and said there was a Firewall blocking it. I had disabled the McAfee Firewall and the Vista Firewall was already disabled for some reason.
Yet the download patch stops at 21% and then still says there is a firewall.
The tech support at Dell tells me it must be because WoW is not yet compatible with Windows Vista.
Anyone out there have Vista and WoW and both works fine?
What else could it be?

04-19-2007, 10:08 PM
This is a blatant lie.

I still use Windows XP but there are many people who've been able to run WoW fine with Windows Vista (beta and live).

The Official WoW Technical Support Forums might be a good place to check.

04-20-2007, 10:22 AM
I thought I posted here....I guess not O.O

There are better places to get patches, try Fileplanet or something similar ( Blizz lists some in their knowledge base as well ). I have had a hard time downloading any sizeable patch through their downloader. Under 5mb seems ok, above that and it just hangs.

Personally I use Fileplanet.

04-20-2007, 04:55 PM
I can also confirm that this is a lie, I play on WoW with Vista all the time.

04-21-2007, 08:35 AM
i have dell xps and i cannot get the wow to set up. I tried disks and then i get message after downloader "wow-partial-1.mpq appears to be corrupt. I tried dowloading off wow site and then i tried patches separate from downloader with fileplanet or whatever thats called.
nothing works
Any ideas please?

04-21-2007, 08:38 AM
i just got my new computer with vista, and wow works perfectly

04-29-2007, 07:42 PM
I've heard this a lot. WoW works just fine with Vista here. You have to launch it as Administrator on patch day, but that's all.

Oh and hi, been a while etc, hope TDG is ticking along nicely.

06-12-2007, 04:32 PM
Its your Anti-Virus. I have a Dell Inspirion 1501e Vista. After 10 mins it continues. If it doesn't on your machine, then its your AV setup.

06-13-2007, 12:07 AM
Post necromancy! ;)

06-13-2007, 01:54 PM
I've been able to run wow fine on Vista from the beginning also.

06-13-2007, 02:47 PM
Post necromancy! ;)


06-18-2007, 03:55 AM

I work as a tech on Dell Business Support. Even though I do not support inspiron / dimensions I know for a fact that this should work...

GIve me the name of the tech you talked to and I'll give him some flaming ;)

Seriously, I have a mate who has a XPS and he has Vista on that, no problems at all..

06-18-2007, 06:49 AM
From what I've read Vista is just teh crap, don't know as I haven't tried it much, but when I was to install Civ4 on my sisters new comp with Vista, I get some error when I tried to load it saying that this program have compatible problems with WinVista.

Read somewhere that not many games but those especially made for Vista (i.e Micro$oft games/program) work with it, doubt this tho, but stilll have problems.

In my case, does DirectX 10 has something to do with it, does seem strange to me but many posts Ive read about games+vista points towards DirectX 10, could that really be it ?

06-18-2007, 07:52 AM
I run Civ4 and WoW on my machine and they both have no problems with Vista. Just click the "I don't give a crap"-button in the incompatibility-dialogues and you are good to go.

But still, Vista is not a good operation system. It is slow, buggy and, at least for me, offers no advantages over XP (or even Win2k). So stay away from it!